• IP Copied!
    Click to Copy IP
    Loading...
  • Click to Join
    Loading..
  • Denied Make it so we can play on 1.7

    Droqqinq

    New Member
    I think making it so is also playable on 1.7 is a good idea.

    like come on, who is going to play on 1.9 1.10 1.11 1.12 1.13 1.14 1.15 1.16. Perhaps
     

    AkuroPlays

    Helper
    Hello! Thanks for making a suggestion. Please use the correct format next time which can be found here.

    For your suggestion, I like it as it allows newer versions to join. 1.17 support might be added in the future when plugins are updated and playable with the version. +1